TiVo Help forums

At beginning of post row.
(Last Login: Jul 18, 2017 at 7:24:24 PM) hotrod2448
0 followers
2nd Dead Bolt in roughly a year
Jul 16, 2017 at 1:45:52 PM  |  #1

A year and a half ago I got a Tivo to avoid TWCs crappy equipment. Unfortunately my experience with Tivo seems to be even worse. Last year I had a bolt die for no apparent reason, came home from the store and it was dead, no lights, no fan, no hard drive spinning. 

 

That was less than a year ago, yesterday I come home and turn the Tivo on to be greeted with no picture or sound. The screen would occasionally flash a static bar across the bottom of the screen. There are lights, the fan is running, the hard drive seems to be spinning but, no picture or sound output. 

 

I've tried all the usual stuff "fixes" with no improvement. Unplug it, different HDMI cable, different HDMI port on the TV. I even went into the menu where you hold pause at startup and enter a code to force a software update or debug, no avail.


Tivo support is closed for the weekend so, no help there. I'm beyond annoyed that I purchased this equipment (I have a mini too) and now none of it functions because the main box is a POS and I have no solution to get a working unit in a reasonable time frame. At least with crappy TWC I could swing by the store and trade out the box. 


Right now I'm using my PS4 to run a free trial of Vue and if it comes down to me paying another $50 for another box I'm going scrap TiVo and cable altogether. Your move TiVo.

At beginning of post row.
(Last Login: Oct 17, 2017 at 8:39:55 PM) tivosupport_ivory
tivosupport_ivory
0 followers
Jul 16, 2017 at 3:11:30 PM  |  #2

Hi hotrod2448

We do apologize for the trouble you're having on your TiVo device. You can also try pressing the INPUT button on your TiVo remote  or the INPUT or SOURCE button on your TV remote to select the right input for your TV to see picture and have the audio. 

At beginning of post row.
(Last Login: Jul 18, 2017 at 7:24:24 PM) hotrod2448
0 followers
Jul 16, 2017 at 4:54:47 PM  |  #3
Quote:
Originally Posted by tivosupport_ivory View the original post

Hi hotrod2448

We do apologize for the trouble you're having on your TiVo device. You can also try pressing the INPUT button on your TiVo remote  or the INPUT or SOURCE button on your TV remote to select the right input for your TV to see picture and have the audio. 

 

I need someone from your customer retention department to contact me ASAP.

At beginning of post row.
(Last Login: Oct 17, 2017 at 8:39:55 PM) tivosupport_ivory
tivosupport_ivory
0 followers
Jul 16, 2017 at 5:12:54 PM  |  #4

We apologize that we cannot have someone call you because of high volume of calls. However, you can reach our Customer support for further assistance on your TiVo device. They can be reached at 877-367-8486 (Weekdays- 7AM to 6PM PST, Weekends- 8AM to 5PM PST). Thanks.

Number of people who have bookmarked this Bookmarked by: 0  
Number of times this has been viewed Read by: 40
Options
Subscribe with RSS Subscribe with RSS
:
Members who like this